Sunday, 29 July 2007

Himerge unmasked - (GHC too!)


Today I have just unmasked the himerge-0.13 package in the official Gentoo portage tree, so you only need to accept the testing ~amd64 or ~x86 keywords for now to install himerge. I expect to get the ebuild stabilized within the next few weeks too.

himerge-0.13 depends on ghc6.6 , so you have guessed right, ghc and many other packages depending on this compiler version have recently been unmasked too in the Gentoo tree, and if you even stop by #gentoo-haskell on the irc freenode network, you will see our team is pretty happy about it :-) ; and the stabilization process has also immediately started , since most of these packages have already been well tested by many users from our Gentoo-Haskell overlay since many months now, it's a matter of a few days until we probably can have all the packages stable in the portage tree.

Feel free to report me directly any himerge bug, or/and you can also send reports about any Haskell packages in Gentoo to our team email address at haskell_at_gentoo_dot_org

Regards and Enjoy!

3 comments:

Mickael said...

Hi,

thank you very much for your work. Himerge is a Magnificent GUI, and it's worked perfectly on my box (~x86). I have not tested all the features of Himerge yet, but given that it uses eix, why not to replace the emerge sync command by that of eix: eix-sync. It is just a suggestion :)

Thanks again.

Mickael.

(Sorry for my english)

Mickael said...

I've got a little problem when I try to open the Use flag editor (Crtl + F) :

himerge: src/UseFlag.hs:135:23-56: Irrefutable pattern failed for pattern (var, (_ : val))


This does not appear with the Packages Branch.

Mickael.

araujo said...

Thank you mickael, i am glad to hear Himerge works fine for you.

I have just released the 0.14 version of Himerge , where the USE flag browser (among many other things) has been greatly improved and this problem should be fixed now.

Thanks and Regards,